Windows 10 October 2018 Update y algo más.

Según cuentan en muchos medios que, sobre el tema del Windows 10 October 2018 Update, se borraban los ficheros de 'Mis Documentos'.
He de decir que, al respecto, uso Windows 10 Pro, con la compilación 17763.1, y...puedo decir con muchísima tranquilidad, que no me ha borrado absolutamente nada (hasta ahora).
He mirado a reojo todo, y no veo ningún problema, hasta ahora. Esto sí, Windows 10, en un portátil como éste, que es un Inspiron 1720, se está poniendo cada vez más lento en cada actualización (en mi caso, particularmente, a través del Insider Preview, lo veo bastante normal)
El caso es, que aunque, Microsoft lo haya cancelado de sus sistemas, yo tengo la ISO del October 2018 Update (64 bits) en mis manos, aún mucho antes de que se armara el follón del borrado masivo de 'Mis Documentos'.
Puedo dar fe que, con mucha tranquilidad, si se hace una instalación en limpio, no traen estos problemas. De ninguna forma.
Recomiendo a todo quién haya actualizado al Win 10 Octob…

COÑE...ahora...

Buscando un poco, encuentro esto: https://patchwork.kernel.org/patch/10185397/

Y sí. Parece ser que sí, éste debería funcionar el portátil este con los consabidos módulos a funcionar con kernel 4.15, bajé el kernel 4.15.3, y sí, funciona, pero con esos módulos que 'no se decía' a que no funcionasen.

Si es que...el fallo estaba en esta línea que está en el código fuente y...cambiando un poco, con estas líneas que pongo:

diff --git a/drivers/ssb/Kconfig b/drivers/ssb/Kconfig
index 71c73766ee22..65af12c3bdb2 100644
--- a/drivers/ssb/Kconfig
+++ b/drivers/ssb/Kconfig
@@ -32,7 +32,7 @@  config SSB_BLOCKIO
 
 config SSB_PCIHOST_POSSIBLE
  bool
- depends on SSB && (PCI = y || PCI = SSB) && PCI_DRIVERS_LEGACY
+ depends on SSB && (PCI = y || PCI = SSB) && (PCI_DRIVERS_LEGACY || !MIPS)
  default y
 
 config SSB_PCIHOST
Y...lo más chocante de todo, es que, cuando hacía 'make prepare' no me quería que se me mostraran las cabeceras de las PCI's que se querían mostrar para que funcione el kernel decente.

Me hace pensar que, en el código no se pensó que se debía haber hecho así en los posteriores kernel's.

Pero ya dicen, que en el 4.16 para arriba, se soluciona este problema (a ver si es verdad).

¡Si no lo llego a saber esto...me mato...! ¡Ya furula! A ver si esta noche duermo tranquilo...con esto...de una vez por todas.

Comentarios